Back to overview
Downtime

Pixify Black, Pixify Edge, Senditure Email Marketing Platform, Startable Web Portal, and 2 other services are down

Jun 21 at 08:45am BST
Affected services
Pixify Black
Pixify Edge
Senditure Email Marketing Platform
Startable Web Portal

Resolved
Jun 21 at 09:28am BST

Senditure Email Marketing Platform and Startable Web Portal recovered.

Updated
Jun 21 at 08:53am BST

Pixify Edge recovered.

Updated
Jun 21 at 08:50am BST

Pixify Black recovered.

Created
Jun 21 at 08:45am BST

Pixify Black, Pixify Edge, Senditure Email Marketing Platform, and 1 other resource went down.